Version 3

<!-- pom.xml -->
<dependency>
    <groupId>com.aventstack</groupId>
    <artifactId>extentreports</artifactId>
    <version>3.1.3</version>
</dependency>

Version 2 (Obsolete, use version 3)

<!-- pom.xml Version 2.x -->
<dependency>
    <groupId>com.relevantcodes</groupId>
    <artifactId>extentreports</artifactId>
    <version>2.41.2</version>
</dependency>

Klov

Klov is supported by all versions 3.1.0+.

ExtentX (Obsolete, use Klov instead)

Supported versions:

  • ExtentReports Java Pro 3.0.0+
  • ExtentReports Java Community 3.0.1+
  • ExtentReports .NET Community 3.0.0+